The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
possible bad coolant level sensor (archive)

[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]

Posted by nt on September 11, 2000 at 14:42:20:

In Reply to: Check coolant level posted by T on September 11, 2000 at 14:34:00:


I have been getting this check coolant level error message on my m3 for about 3 weeks now and i have had the car for 7 weeks. To give some history of the car since I have bought it. When I first bought it, it took quite a long time to get the engine temperature up to run temp. So I had the dealership put in a new thermostat because it wouldn't cycle soon enough. Everything works fine, then I get a check coolant level error message on the obc when I start and stop the engine, but the coolant level was fine. I recently had the engine overheat, due to a bad water pump, which got replaced. Ok, so I think the worries are over, no, I am driving along and the temp goes up and overheats. I get it towed to a dealership. The problem there was an air bubble was in the cooling system, thus shutting off the thermostat when it would go over the thermostat. So the dealership flushes the system and "burps" it. The car is working fine now, BUT now I get this pesky check coolant level on start up and when I shut it off, it last for about a minute on the obc then turns off, any ideas?????

T





Follow Ups:



[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.