The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Help - car running hot (archive)

[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]

Posted by lincoln on October 03, 2000 at 15:18:19:

In Reply to: Re: Help - car running hot posted by Bob ///M3 on October 02, 2000 at 13:03:15:

It's been flushed within the last 24 months. The fan clutch is new. The waterpump impeller should be metal (may 96 production). The aux fan in front of the radiator runs when the AC is on. I don't know how to check a themostat, but it almost gotta be this or a clogged core??? BTW: The coolant looks pretty good in the overflow bottle...


That also sounds like symptoms of a clogged radiator core. Has the coolant been flushed and replaced since the car was new?

Also, I guess there is a chance you have the plastic (circa '95 and some '96s) water pump impeller that could have lost a fin or two.

Bob ///M3

A few weeks ago my '96 M3 started to run hot at idle and cool when under way. My mechanic replaced the fan clutch since this is a common symptom of this problem. So I have a new fan clutch, but still have the same problem??? So far the car hasn't overheated, but will run from the middle of the gauge (normal) to just over the 3/4 mark and then back down...Any ideas on what we should replace next would be appreciated.






Follow Ups:



[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.