The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
NOISE on Drive Belt / Pulley Help! (archive)

[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]

Posted by Quake on May 14, 2001 at 09:40:04:

I have been trying to get rid of this noise on the drivebelt for about a month now. I replaced the tensioner pulley and the idler pulley and it solved some of the noise problem but there is still something that like rubs onto something. I changed the H20 pump a year ago so it couldn't be that bearing. I also checked the fan clutch, that isn't it. Now i think it's the Power Steering pump. The pump is working fine and i'm not going to spend $130 if i'm not sure it's the pump's bearing that is the problem. The thing that's odd is when i spray WD40 on the pulley itself, i mean the where the belt goes around to, the noise disappears, but when it dries up the noise comes back. It only happens when the engine is hot. This is driving me crazy and i'm getting VERY Annoyed. Can anybody help? Thanks guys.


Follow Ups:



[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.