The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Crank Angle Sensor (more) (archive)

[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]

Posted by Bill Clark on May 14, 2001 at 23:44:23:

In Reply to: HELP!!!!LOSING POWER(MORE) posted by BUTTERM3 on May 14, 2001 at 01:00:10:

My 97 M3 was doing the same kind of stuff a few months ago. Someone on this board (thanks someone!) suggested it might be the Crank angle sensor. I took the car to the dealer and they checked the computer (DME?) and found many iterations of the Crank Angle Sensor code flags. Then they checked my VIN number and said that my car was included in a campaign to replace the sensor and they did the work at no charge! If you call the dealer with your VIN# they can check to see if your car is included.


Good luck!

Bill


on friday evening I was waiting for my girlfriend to come out of a store an my car just shut off, It ran fine afterwards, then on saturday as I was pulling out of a light my car felt like i was in third I had no power what so ever, so I pulled over shut the car off turned it back on and no problems after that, today I was on the highway and I shifted into fifth the car shut off turn, back on(jerked very bad like I pushed started the car)and I notice that when I went into neutral my rpm needle would drop to about 500 and jump back up...so once again I pull over shut the car off and PRESTO everything is working again no problem, I have a 97m3 4 door with 21,500 miles and a supersprint dtm exhaust. I get the car tuned religiously and had a major tune up performed on the car about 2 months ago(inspection 2) by "the little garage"
where all filters, oils, fluids etc. where changed. what is going on???? also when I would step on the gas to see if it would pass there was a funny smell like when I first purchased the car and the engine was breaking in and the car sounded like I had a hole in the exhaust. I get the usual "brake light circut" and airbag lights is on thanks to the seatbelt sensor but other than that the car runs mint. I put the car on the lift today to see if maybe I had an exhaust leak ..nothing, then one of my friends mentioned that maybe I have bad gas but I dont think it is that because I only fill up at the same gas station and if it where bad gas I think it would happen when I turn the car back on (same gas in the line)please help any suggestions or tips would be very helpful

thanks
Juan





Follow Ups:



[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.