The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Probably battery (archive)

[ Follow Ups ] [ Z3 Message Board ] [ Msg. Board FAQ ]

Posted by Tom Alves on March 02, 2001 at 08:17:18:

In Reply to: Probably battery posted by EricS on March 02, 2001 at 00:32:35:

I have had the exact thing happen to me as well. In my case, the fuse for the security system blew and disabled the starter. It happened when I first bought the car, but never again since.

It has been left in the shop for about 4 months now but it has been started regularly. Just when it was about to come out today it wouldnt start. It is not the battery for sure because all the lights and even the hardtop still works. When I start the car, it doesnt even make that click sound like it usually does when your car is out of battery. Please help me figure this out because I have been waiting for 4 months to get that thing out of the shop.


starting the car occassionally, and not driving it for 10 miles will actually drain battery more than not starting it.





Follow Ups:



[ Follow Ups ] [ Z3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.