The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
I have the Business CD head unit. (m) (archive)

[ Follow Ups ] [ Z3 Message Board ] [ Msg. Board FAQ ]

Posted by Tony S on March 04, 2001 at 17:10:15:

In Reply to: Different experience posted by Jaymo on March 04, 2001 at 16:02:52:


I dunno. That's what I bought from those guys and mine was definitely plug-n-play. No soldering, no anything except locating the harness, plugging it up, and mounting the changer in the trunk. Perhaps we have different models of Z3. Mine's a 2001 2.5 model with the BMW standard tape deck head.

Everything plugged in together fine, the sound was very distored. Autotoys knew about the problem and already had a fix...but the fix was installed on my interface already. They had me install some capacitors in the interface which solved most of the noise but not all of it. So plug and play it was not. With the no return policy and the problems I've had I'd say buyer beware. The customer service at Autotoys I thought they responded very fast but not knowledgable the service tech called capacitors resistors. I would buy from them again but not anything that has to mate to exsisting equipment. I think having a customer perform soldering as part of the fix for a plug and play unit is out of line. I'm MIL spec certified for me no problem but what about the non-technical people on this board....


Follow Ups:



[ Follow Ups ] [ Z3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.